1
Reply

WCF Service connectivity issue

umair ahmad

umair ahmad

Jun 16 2015 11:09 AM
826

I have added https://www.retirementlogin.com/spectrum/RAConnectBasicWcf.svc service URL into our project but it gives following error,

he HTML document does not contain Web service discovery information.
Metadata contains a reference that cannot be resolved: 'https://www.retirementlogin.com/spectrum/RAConnectBasicWcf.svc'.
Content Type application/soap+xml; charset=utf-8 was not supported by service https://www.retirementlogin.com/spectrum/RAConnectBasicWcf.svc. The client and service bindings may be mismatched.
The remote server returned an error: (415) Cannot process the message because the content type 'application/soap+xml; charset=utf-8' was not the expected type 'text/xml; charset=utf-8'..
If the service is defined in the current solution, try building the solution and adding the service reference again.

It looks like the problem is with the configuration file so we have added configuration settings as suggested but it is not working following is the configuration we have added,

<?xml version="1.0"?>

<configuration>

<system.serviceModel>

<bindings>

<basicHttpBinding>

<binding name="basicHttp" allowCookies="true" messageEncoding="Text" textEncoding="utf-8"

maxReceivedMessageSize="20000000"

maxBufferSize="20000000"

maxBufferPoolSize="20000000">

<readerQuotas maxDepth="32"

maxArrayLength="200000000"

maxStringContentLength="200000000"/>

</binding>

</basicHttpBinding>

</bindings>

<services>

<service name="ReliusConnectClient.RAConnectBasicWcf" behaviorConfiguration="ReturnFaults">

<endpoint address="https://www.retirementlogin.com/spectrum/RAConnectBasicWcf.svc" binding="basicHttpBinding" contract="ReliusConnectClient.IRAConnectBasicWcf">

</endpoint>

<endpoint contract="IMetadataExchange" binding="mexHttpBinding" address="mex" />

</service>

</services>

<behaviors>

<serviceBehaviors>

<behavior name="ReturnFaults">

<!-- To avoid disclosing metadata information,

set the value below to false and remove the metadata endpoint above before deployment -->

<serviceMetadata httpsGetEnabled="true" httpGetEnabled="true"/>

<serviceDebug includeExceptionDetailInFaults="true" />

</behavior>

</serviceBehaviors>

</behaviors>

</system.serviceModel>

</configuration>

 
please tell me what i am doing wrong

Answers (1)